I thought this was going to be more difficult than it was. If you want to manage multiple versions of the same package in bower, your bower.json dependencies can look like this:

 "dependencies": {
    "jquery-1.9.1": "jquery#1.9.1",
    "jquery-1.8.1": "jquery#1.8.1"
    }

The first part of the declaration gives it a name (I could call them jquery-old and jquery-new if i wanted), and that # specifies the version of the package you want to install.